Py-chemshell 21.0.3 test


For the past few weeks, I have been trying to compile and install chemshell 21.0.3. After the compilation was complete, I ran the chemsh command and everything seemed to go smoothly. Unfortunately, I tried to use run_validation.tcsh to test whether I could compute with QM/MM smoothly, but the results showed almost all failures.

The environment conditions in my system are: cmake-3.26.4, gcc-9.4.0, gulp-5.2, openmpi-3.1.4, orca-4.2.1.The database required by the software has also been installed.

Run the following command:

./setup --mpi --fc mpifort --cc mpicc --cpc mpic++ --gulp /home/cy/chemshell-py/Software/gulp
-5.2-for-chemshell --mpi_lib_path=/home/cy/chemshell-py/software/openmpi-3.1.4/lib
–pythonlib=/home/cy/chemshell-py/software/Python-3.10.4/lib/ --pythoninclude=/home/cy/chemshell-py/software/Python-3.10.4/include/python3.10

The following results occur:

When I run validation.tcsh*, I get the following result:

I can understand errors except for ORCA and GULP, but I can’t understand why ORCA is half OK and half failed, and GULP is all failed. Due to the lack of relevant knowledge reserve, this is a difficult problem for me to solve. Do you know why that is? I would appreciate it very much if you could give me some help.

Appreciate any suggestions.

Best regards,


Hi Chen,

It looks like GULP could not be found when running the GULP tests, and judging by how quickly ChemShell compiled I suspect it could not be found when compiling ChemShell either. I think you need to double check the GULP path (e.g. is it really “Software” and not “software”, as with python?). But also you should use a newer version of GULP, as we no longer test with v5 now that v6 is available.

For ORCA, there may be some incompatibility between ORCA’s MPI environment and ChemShell’s, depending on the platform. The easiest solution to this is usually to compile ChemShell in serial, which shouldn’t affect overall performance too much assuming that the QM calculations with ORCA will take much longer than the rest of your QM/MM simulation.

Hope that helps,


Thank you for your reply. As for the gulp part, I can confirm that I did not fill in the path incorrectly during the compilation process. I may have made a mistake in the forum before. I tried version 6.0.0 again, but the problem was not solved. Perhaps, as you said, the software is incompatible with chemshell. Would you like to ask what QM software can be replaced with better parallel on chemshell? Would you like to ask if I need to modify the compilation command? I look forward to your reply and wish you a happy life.


Based on a similar experience, it is worth checking if you are building on top of a previous installation which succeded partially and created a libgulp.a and If these already exists and if you are giving a second try for some reason without cleaning it up, the build skips the parts which were already compiled and create a new, possibly wrong This can be checked by building in a new directory with a fresh download of chemshell and gulp and see if the issue is the same. A fresh installation should throw errors if it cannot find and link the gulp. If you have the complete log instead of the last part, it is easier to see if this is happening.

Thank you very much for your reply. I don’t quite understand what you mean. I’m not sure if it’s clean. Is there any way to check the results? I have no particular understanding of this part. For GULP, I followed the online tutorial to download and extract the installation package to the home directory and add the environment path. As explained in the tutorial, Chemshell will automatically compile the GULP library and put it in the appropriate place. This problem has been bothering me for a long time, and I would really appreciate it if you could help me solve it.

Hi Yi Cheng,
Sorry, it was not clear. Your issue may not necessarily be what I suggested. But to give it a try, can you just do a fresh install?You don’t need to install gulp. Just download and decompress a fresh copy in a new directory and download chemshell also. And install chemshell with ./setup other-options-you-want --gulp gulp_directory_name > chemshell.log. Please save the log file, e.g., here chemshell.log. Don’t link other software at this stage, like orca. And see what the logfile says. If it fails, please don’t try a second time. That’s what I meant last time. You can post the log file here. Best wishes.

Thank you for your reply. I re-downloaded and decompressed GULP, and compiled chemshell. Unfortunately, there seems to be some problem, I uploaded some information, can you help me find out where the problem is? Thank you very much.

Sorry, this screenshot is not clearly visible. Could you please provide the install setup command you used? Have you installed in a new directory for chemshell? If possible, could you attach the log info as a text file in the original form? I am not sure if the screenshot you shared is the full form of the log info. I can’t see any compilation part of gulp there. It would be helpful if you provide the full file. Or have you installed in an old directory of chemshell?
Edit: okay, I could magnify and read your screenshot. It can be seen that gulp is built. What exact problem are you facing now? Has the compilation completed successfully ? Can you still answer the other questions pls?

Thanks for your reply, my initial problem was that when I ran the test script after compiling, the output showed that it could not link to GULP (I compiled it ahead of time, probably I should not have compiled it ahead of time). Later, according to everyone’s suggestions, rebuild the directory, re-download and decompress GULP, and wait for chemshell to compile it. In this case, the./setup compilation will not complete, and the display will be missing some link libraries. Stuck in the compiled "link Fortran executable… /chenshell-py-21.0.3/bin/gnu/chemsh.x(as shown in my screenshot), I was very confused, I prepared the underlying environment and database according to the guide of the official website, why did this problem occur? I hope to get your guidance and help, thank you very much.

Can you confirm that this time you built in a newly created directory for chemshell and not in a directory you previously tried your builds?

Yes, for sure. I confirm that this time I built it in a newly created directory for chemshell.

can you give the full ./setup command you used? And the full output?

Looks like your new problem is not the original problem posted here. You can give another try and see if the build process completes.

I have rebuilt the underlying environment again, without using the./setup command to try to compile chemshell.
I’m going to try ./setup --mpi --fc mpifort --cc mpicc --cpc mpic++ --gulp /home/cy/py-chemshell
/software/gulp-6.0 --mpi_lib_path = / home/cy/py - chemshell/software/openmpi - 4-1.1 / lib --pythonlib = /home/cy/py-chemshell/software/Python_3. 9.16/lib/python3.9.So --pythoninclude =/home/cy/py -chemshell/software/Python_3. 9.16/ include/python3.9
Because the official website says to use openmpi parallel build:./setup --mpi --fc mpifort.openmpi --cc mpicc.openmpi, but I can’t use this, it seems that the openmpi of mpifort.openmpi is a little redundant. I specify the location of openmpi and the python library and header files and the gulp directory I want to compile. This is what I want to express in the command, but I am not sure if it makes sense. Because I have failed too many times, I do not dare to try easily, hope to get your advice, thank you very much

As for the gulp problem, I can suggest you run a ./setup --fc mpifort --clean before trying every new build of chemshell. Also delete the folder chemsh/interfaces/gulp/CMakeFiles. This should rebuild gulp completely. I don’t quite understand the new problem without any log information. The build process is just stuck and not completes, that’s strange. I hope someone knowledgeable can help you here. Best wishes.

Hi Chen,

As I mentioned in my first reply, I strongly recommend you compile ChemShell in serial (no MPI compilers and no MPI option) in order to use it with ORCA.

For GULP, I suggest you compile as a standalone code (outside of ChemShell). Check GULP is working on its own first (don’t skip this important check!) and then put it in your PATH so that ChemShell will call it via a system call. There is no performance penalty to this.

Also it might be worth trying a newer GNU compiler than v9, if available.