Chemshell 21.0.3 compilation problem


I’ve been trying to compile chemshell 21.0.3 for the last couple of days. The compilation seems went through, unfortunatly the chemsh didnot work well.

The package is compiled with the following command in virtual enviroment with python 3.8.16, numpy 1.24.3, intel compiler, MKL library and cmake 3.26.4:

/setup --mpi --fc mpiifort --cc mpiicc -j 30 --dl_poly --fftw /opt/ohpc/pub/libs/gnu8/mpich/fftw/3.3.8/lib --fftw_include_dir /opt/ohpc/pub/libs/gnu8/mpich/fftw/3.3.8/include --cpc mpiicpc --pythonlib /usr/local/lib/python3.8/ --prepend-pythonpath /opt/ohpc/pub/apps/chemsh-py-21.0.3/chem-env/lib/python3.8/site-packages/ --pythondir /usr/local/include/python3.8/ --mkl /opt/intel/mkl/2021.3.0/lib/intel64/ --mpi_include_path /opt/intel/mkl/2021.3.0/include/ --mpi_lib_path /opt/intel/mkl/2021.3.0/lib/

Unfortunately, after compilation the command “chemsh” didnot work with the following error messages:

In, it is only for sanity check, with the following contents:

from numpy import *
from chemsh import *

Do you have any idea why this is happening? That would be really help.

Appreciate any suggestions.

Best regards,

By the way, I tried the debug run as suggested on the official website.

It turned out python could not find module chemsh.

error message:

from chemsh import *
ModuleNotFoundError: No module named ‘chemsh’


it seems likely that chemshell is not in your python path, have you tried running the command:

export PYTHONPATH=[complete path to chemshell]/chemsh-py:$PYTHONPATH

before running the python chemshell script.

Please let me know if this works, if not I will try to assist further.